1

Тема: Не понятки с 3G модемом ZTE MF190

Имеем keenetic подключенный через 3G модем (MF190-2.0.0 ПО-BD_RUBLNMF190-V1.0.0.B01) к интернету, модем предварительно переведен с помощью 3G_modem_switch в режим только модема и подключен через usb hub (kreolz hub07b) к hub подключен так же винт со своим питание и камеры по wi-fi. 
На выделенном канале интернет все работает, камеры пишут, пробуем 3G проблемы.
Интернет нужен только для того чтоб взять время и дату, на момент перезапуска или включения.

Стартуем все подключилось, но проходит некоторое время разрыв - ошибка протокола. Инициализация потом подключение, или ошибка в инициализации. Камеры теряют доступ к samba хотя по ps -> samba весит в запущенных процессах.
Перезапуск может помочь, а может и нет даже интересные зависоны бывают на инициализации демонов у keenetic:
...
3833 root       1032 S   /sbin/mdev block
3835 root       1032 S   /sbin/mdev block
3845 root       1032 S   /sbin/mdev tty
3848 root       1032 S   /sbin/mdev usb-serial
3849 root       1024 S   sh -c /bin/automount.sh $MDEV
3851 root       1024 S   sh -c /bin/automount.sh $MDEV
3860 root       1032 S   /bin/sh /bin/automount.sh sdb1
3862 root       1024 S   sh -c /bin/modem-setup.sh $MDEV
3868 root       1024 S   sh -c /bin/modem-setup.sh $MDEV
3874 root       1032 S   /bin/sh /bin/automount.sh sdb3
3877 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
3883 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
3974 root       1032 S   /sbin/mdev tty
3989 root       1024 S   sh -c /bin/modem-setup.sh $MDEV
3996 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
4012 root        848 S   dnsmasq -u root --all-servers -k
4017 root       1024 D   grep -q Vendor=19d2 ProdID=0001 /proc/bus/usb/devices
4018 root       1024 D   grep -q Vendor=19d2 ProdID=0001 /proc/bus/usb/devices
4028 root       1032 S   /sbin/mdev tty
4029 root       1032 S   /sbin/mdev usb-serial
4038 root       1024 S   sh -c /bin/modem-setup.sh $MDEV
4045 root       1024 S   sh -c /bin/modem-setup.sh $MDEV
4058 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
4059 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
4084 root       1024 D   grep -q Vendor=12d1 ProdID=1003 /proc/bus/usb/devices
4087 root       1024 D   grep -q Vendor=12d1 ProdID=1003 /proc/bus/usb/devices
4097 root       1024 D   grep -q Vendor=12d1 ProdID=1003 /proc/bus/usb/devices
4108 root        820 S   miniupnpd -a 192.168.1.1 -i ppp0
4145 root       1020 S   /bin/sh /bin/setup_users.sh
4150 root       1020 S   /bin/sh /bin/setup_cifs.sh
4151 root       1032 S   /bin/sh /bin/setup_samba.sh
4154 root       1020 S   /bin/sh /bin/setup_users.sh
4156 root       1020 S   /bin/sh /bin/setup_cifs.sh
4158 root       1032 S   /bin/sh /bin/setup_samba.sh
4261 root       1024 S   vsftpd
4289 root       3088 S   nmbd -D
4290 root       2904 R N smbd -D
4295 root       2904 R N smbd -D
4982 root       1492 S   /bin/cli
5046 root       1060 S   /bin/sh /bin/pppd.sh connect
5068 root       1024 R   ps
5069 root       1020 R   pidof pppd
...

Диагностика вот что говорит:
# cat /etc/version
--------------------------------------------------------------------------------
FIRMWARE_VERSION="V1.00-BFW.4b-D0"
DEVICE_NAME="KEENETIC"
BUILD_DATE="17.09.2011 02:39"
REVISION="3060"
...
# cat /proc/bus/usb/devices
--------------------------------------------------------------------------------
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  2, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.23.17 dwc_otg_hcd
S:  Product=DWC OTG Controller
S:  SerialNumber=lm0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 10 Spd=480 MxCh= 4
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=05e3 ProdID=0608 Rev=77.64
S:  Product=USB2.0 Hub
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   1 Ivl=256ms

T:  Bus=01 Lev=02 Prnt=10 Port=01 Cnt=01 Dev#= 11 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1bcf ProdID=0c31 Rev= 1.32
S:  Manufacturer=Sunplus Innovation Technology
S:  Product=USB to Serial-ATA bridge
S:  SerialNumber=FDC0FD500000000FD0FFAFF2015508
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

T:  Bus=01 Lev=02 Prnt=10 Port=02 Cnt=02 Dev#= 12 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=19d2 ProdID=0016 Rev= 0.00
S:  Manufacturer=ZTE,Incorporated
S:  Product=ZTE WCDMA Technologies MSM
C:* #Ifs= 3 Cfg#= 1 Atr=e0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbfs
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms

Вот такая петрушка.

2

Re: Не понятки с 3G модемом ZTE MF190

Почему камеры перестают писать понял, перемонтирование томов в имя другое от DISK_A1 => DISK_B1, зачем???

3

Re: Не понятки с 3G модемом ZTE MF190

vasek00, это не форум поддержки продукции ZyXEL. Поддержкой занимается "Интерактивная Система Консультаций" на zyxel.ru. Если hdd перемонтируется и меняет току монтирования - проблема с hdd (плохая совместимость с контроллером кинетика, нехватка питания, засыпание hdd). На zyxel.ru, возможно, больше информации по разным моделям hdd.
Бывают еще проблемы с некоторыми usb хабами. OTG контроллер кинетика поддерживает максимум 4 usb устройства (включая хаб). У Вас, похоже 7 портовый. Если есть другой - попробовать с ним, попробовать с активынм usb хабом (может это поможет модему). Модем рекомендуют перевести утилитой производителя в режим "только модемм".

4

Re: Не понятки с 3G модемом ZTE MF190

По винту не соглашусь, так как при нормальном канале интернета винт работает уже несколько дней без проблем круглосуточно, камеры с датчиком движения, если в ночное время движения нет, то и потока видео нет - винт засыпает, под утро пошло движение поток видео пошел винт проснулся (С ЭТИМ ПРОБЛЕМ НЕ БЫЛО) - и вот в таком состоянии работает все нормально записано более 30*2 = 60GB.

Речь про другое, когда пропадает интернет на 3G (в данном случае ошибка - протокола, а потом не обнаружено устройтсво) то система запускает опять :

3874 root       1032 S   /bin/sh /bin/automount.sh sdb3
3877 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
3883 root       1052 S   /bin/sh /bin/modem-setup.sh ttyUSB0
...
4145 root       1020 S   /bin/sh /bin/setup_users.sh
4150 root       1020 S   /bin/sh /bin/setup_cifs.sh
4151 root       1032 S   /bin/sh /bin/setup_samba.sh
4154 root       1020 S   /bin/sh /bin/setup_users.sh
4156 root       1020 S   /bin/sh /bin/setup_cifs.sh
4158 root       1032 S   /bin/sh /bin/setup_samba.sh

поэтому и происходит монтирование на другую точку DISK_B1
Как уже было написано модем был переведен утилитой в режим просто модем. У меня два устройства USB включая HUB: usb модем, и порт для винта у винта свое питание, как видно из поста выше :
S:  Product=USB to Serial-ATA bridge
S:  SerialNumber=FDC0FD500000000FD0FFAFF2015508
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA

Переключаю на обычный Интернет по проводу проблем нет.

Что-то мне эта "Интерактивная Система Консультаций" не очень но попробую.